Message "OS not compatible" when installing Safetica on endpoints

When installing Safetica to endpoints via Update and Deploy screen or via Endpoint Management screen, you may encounter the message "OS not compatible". The station will have Safetica Agent installed, but not Safetica Client. In case you were updating Safetica on the station, the Safetica Client will remain in the old version.

This message is shown when the station does not support DualSign driver certificates, or has SecureBoot enabled in their UEFI (BIOS). This situation can be solved by installing missing Windows updates on the stations. The requirements for installing Safetica are:

Windows Vista x64 and Windows 2008 Server (without R2) are not supported due to missing support for DualSign certificates. All other Windows versions support DualSign certificates and do not require specific Windows Update.